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Description

Discovery Pro is a virtual analog synthesizer emulation for AAX, Audio Units, VST2, VST3 
hosts and standalone app, featuring multi-layering, parameter morphing, high-quality 
sound, WAV and SF2 support, PADSynth re-synthesis and straightforward interface.

Installation

● Apple OS X

Run the installer and follow the instructions.

● Microsoft Windows

Run the installer and follow the instructions.

● Linux

Run install.sh with Terminal or

Place discoDSP folder at /home/username/Documents/
Place DiscoveryPro64.so at your VST folder, usually /home/username/.vst/
Place DiscoveryPro64.vst3 at your VST3 folder, usually /home/username/.vst3/

Demo version will be unable to store any current synth state or save banks. Bounce, 
automation and some Edit functions are disabled.
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Features

Discovery boasts the following powerful feature set:

● 128 Patch Memories per bank.

● Parameter Morphing using Modulation Wheel or MIDI velocity.

● 2x oversampling / 2x oversampled distortions.

● Bank browser (by clicking arrows in display led and bank name).

● More than 5.000 presets in 100 banks (including a percussion one).

● Nord Lead 2 and 2X patch import and export.

● 4 Layers per Patch, each with:

○ 2 Oscillators (Sine, Saw, Triangle, PWM, Square, Parabolic, White and Pink 
Noise) with Ring modulation, Sync, Frequency Modulation and Phase Reset 
Trigger.

○ 1 Wave Oscillator. Can load WAV and SoundFont 2 (SF2) files using high quality 
interpolation with PAD re-synthesis generation. User banks are easily added 
using EDIT > File.

○ Resonant Filters (LowPass, HighPass, BandPass, BandReject, Formant, 8 taps 
phaser, X 12/24 dB and Y 12/24 dB are Moog modeled).

○ ADSR for Amp & Filter. Amplitude envelope can switch between linear and 
exponential curves.

○ 2 LFOs.

○ Modulation Envelope.

○ Graphical Modulation Envelope.

○ Arpeggiator.

○ Built-in Unison, Chorus, Phaser, Panning Delay and Gate effects.

○ Symmetric, Asymmetric and Asymmetric 2 Distortions.

○ Limiter.

○ Poly/Mono/Legato modes.

● MIDI CC control.

2



Basic Concepts

Channel Limiting and Oversampling
You may now determine the number of channels used in the instrument by left-clicking 
the "voices" LED or at EDIT > Config.

A dialog box will appear with the number of voices you wish to enable. Select the desired 
voice number.

You can select the Playback Quality oversampling mode, 
where 2X makes Discovery work internally at 88 kHz 
when your host is set to 44.1 kHz with a separate 
oversampling setting also available for Bounce 
operations.

HQ Distortion will duplicate distortion's internal 
frequency rate, depending of the oversampling mode 

mode and resulting into 4X in case a global 2X has been configured.

Quick program select
Left-click program LCD panel to see a list of available patches.

Bank browser

You are able to browse all the FXB banks by clicking the arrows in the status LCD or 
clicking the bank name to display a drop-down menu. All banks are located at 
Documents > discoDSP > Discovery Pro > Bank folder. You can add your own banks 
using EDIT > File > Import Bank function.

For easier preset and banks management, EDIT > File > Open functions will bring a 
Finder or Explorer window.

There is a subfolder called User.dwb where WAV files can be copied and recognized 
instantly after each menu drop-down click, providing better workflow. There is a quick 
access for this folder using EDIT > File > Open Data Folder. WAV files can also be 
imported using EDIT > File > Import Wave function.

Also, there is a Disk Mode that reads .FXP programs from the subfolders located at 
Documents > discoDSP > Discovery Pro > Presets > Programs folder. Click 'Bnk' to 
switch to Dsk.
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Morphing state knob editing
In normal mode, holding Ctrl / Bwhile moving the knob will modify morph 
sensibility. Behavior will be backwards when Morph mode is on.

MIDI Aftertouch knob editing
MIDI Aftertouch can be assigned to any knob. Useful to control LFO speed, filter cutoff, 
resulting in more expressive sounds. In R5.4, aftertouch can be switched to Foot (CC# 4), 
Expression (CC# 11) and Breathe (CC# 2) using EDIT > Switch > Aftertouch To function.

To access Aftertouch mode simply hold Ukey while pressing A, B, C or D button. 
Layer led will start blinking. To go back to normal editing, press again the Layer button.

There is a secondary access located at EDIT > Switch > Aftertouch mode. 

Fine tune knob editing
To have more detailed parameter adjustments, hold Ukey while moving the knob 
to edit both states. Shift and Ctrl keys can be used at once too.
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LFO Sync to host tempo
Discovery’s LFO1, LFO2 / Arpeggiator, Delay and Panning LFO can be synced your host 
tempo. To enable it, just click the led located next to the LFO knob or Delay amount.

Edit operations
There are a set of editing operations, clicking EDIT button on your Discovery GUI offers 
the following options:

● File: Imports or exports Clavia's Nord Lead patches, FXB preset 
bank to exchange between several projects or users. Open 
folders for quick bank, SF2 and PAD SFZ cache files.

Also opens Data, Presets folder and Unison configuration for 
quick access.

● Copy, Paste, Randomize, Reset: Allows to do simple editing 
operations over the current layer, preset, or even selected 
sections from the current preset, like LFO1, LFO2, ADSR and 
other ones.

● Unison: Applies values from text file unison.txt located at 
Documents > discoDSP > Discovery Pro > Config from first 
layer to the other ones. For details refer to Unison edit at the 
end of this manual.

● Rename: Renames current program name. 
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● Key Split:

● Off: Set layers to be played all at once.
● AB/CD: Plays layers A/B from C0 to B3 and C/D from C4 to B9.
● Custom: Plays a custom note range from from C0 to B9 for each layer.

● Programs: This function displays the presets located in the following folder path: 
Documents > discoDSP > Discovery Pro > Presets > Programs. These presets 
can be conveniently saved to disk by using the "File" option and selecting "Save 
Preset To Disk".

● Quick Stack: Allows the active layer to navigate through other presets and banks 
without leaving the current program, loading the first layer from others. To exit this 
mode, click any layer button. A flashing LED indicates that Quick Stack is active. 

● Swap: Enable or disables MIDI Velocity to Program Morphing, FX section or use 
the classic chorus. Enters Aftertouch MIDI editing mode and assignment. Swap 
between Bank and Disco modes. Switches between classic Discovery filter and 
new R6 Nord Lead modeled Zero Delay Feedback filters or from Chorus to Unison 
for the full bank and switches Oscillator Phase Reset mode.

● Tempo Sync: Quickly sync to host tempo LFO1, LFO2, Panning, Delay sections or 
all of them at once. 

● FX Bypass: Disables individual or all effects even after changing presets.

● Config: Selects global plugin polyphony, oversampling or high-quality distortion. 
More polyphony, higher oversampling can result in a CPU hit. It's recommended to 
use higher choices when a project is going to be bounced. MIDI CC button mode 
allows to use alternate MIDI CC map found at EDIT > Help.

● MIDI: Selects MIDI Learn, MIDI CC button mode and MIDI out on/off as well as 
select several MIDI CC hardware boards templates.

● Appearance: Selects skin located from Documents > discoDSP > Discovery Pro > 
Skins and switches window and all their elements between 3 sizes: 1x (400p), 1.5x 
(600p) and 2x (800p).

● Help: Opens tutorials, manual and MIDI CC default table. Also displays Release 
number and checks if there is a new version available.
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Zone presets
Zone presets has been introduced with Release 4. It allows each section to have their 
own presets based on the current state, so they can be stored for later use, allowing 
quicker preset design and getting better overall workflow.

They are stored at Documents > discoDSP > Discovery Pro > Presets folder using a 
standard XML format. Such files can be shared without the need of importing or 
exporting, just copying them to their current folder.

Deleting presets
Hold Ukey while selecting the desired preset to delete. The XML file will be 
removed from the disk.
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Layers

Discovery Pro can hold 128 patches at any one time.  Each patch may contain up to 4 
layers.  Combining layers can be used to create complex sounds that simple subtractive 
synthesis cannot achieve.

Discovery Pro supports up to 128 polyphonic voices. When all four layers are enabled, a 
single note consumes four voices, reducing the total polyphony to 32.

To select a layer, left-click the A, B, C, or D buttons below the Program and Voice 
number LEDs.

Layer A is the default. When a layer is active, the button directly above it is highlighted. 
Selecting any layer (B, C, D) activates it.

If a program includes multiple layers, the selected layer’s button remains highlighted while 
other active layers are disabled. To turn off a layer, left-click it twice, click the highlighted 
LED, or use the on/off button.

You can also switch to Quick Stack mode by holding Ukey and pressing the 
desired layer to apply the Quick Stack. Once finished, click the button again or any other 
button to exit.

To solo or unsolo layers use  Alt / KPclick on Windows / Mac or Right Click on 
Linux. Note that this function will affect all four layers when unsoloing.
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Parameter Morphing

Each layer contains two internal states: morph source and morph sensibility.  Each state 
contains a unique set of all values. Morphing allows you to easily glide between these 
values.

Morph sensibility state is seen using alpha blend, and can be modified by using Ctrl key 
while adjusting the knob. A 32-bit video mode is required to display this transparency.

You can easily toggle between both morph states by left-clicking the ASSIGN button, 
located in the top left of Discovery Pro under the "Morph" label.  When the ASSIGN led is 
active, all parameter modifications are being made to the MORPH state.

Once both states have been defined, you can easily morph between them by assigning 
the Wheel MOD to MORPH mode.  Once set, moving your mode wheel will morph 
between both states.

EDIT > Reset > Layer Morphing sets all layer MORPH sensibility state to zero.

TIPS

● MIDI velocity to Morph can be disabled by clicking the led above modulation wheel 
or using EDIT > Swap > MIDI Velocity To Morph.

● Knobs from four layers at once can be moved using Alt / KPdrag on 
Windows / Mac or Right Click + drag on Linux.
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Global Layer Options

● Oct Shift: Shifts pitch in octaves of the layer.

● Pitch Bend: Pitch bender allows you to drastically change the pitch of the current 
patch in real-time. You can modify the pitch bend range from 1 to 48 semitones by 
clicking the LCD arrows or clicking numbers for a drop-down menu.

● Modulation Wheel: Can be assigned to modulate the following parameters:

○ FLTR: Filter cutoff frequency.

○ FM: OSC2 to OSC1 frequency modulation amount.

○ OSC2: OSC2 pitch.

○ LFO1: LFO1 amount.

○ MORPH: Morph between source and destination morphing states.

● CHR: Left-click the CHR button to enable Chorus, Phaser or both modes at once.  

● UNI: Enables Unison. 2 voices are used on POLY mode and 4 on LEGA/MONO.

● Play Modes:

○ MONO: Only 1 voice of the synthesizer is used for the layer. In this mode any 
note played will discontinue the previous note.

○ LEGATO: A monophonic mode in which envelopes are not restarted when new 
keys are played.

○ POLY: Polyphonic mode allows multiple notes to be played at once.

● Portamento: Portamento glides the pitch between the current note and a newly 
played note.  The higher the value, the slower the transition progresses.

○ Auto: When enabled, glide/portamento will be only applied if overlapping notes 
are played (legato).
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Oscillator Section

Oscillators are the basis of sound generation in subtractive synthesis. Discovery Pro 
includes two primary oscillators, each with various modes and waveform types.

Waveforms available in Discovery Pro are:

Wave Type Useful for creating...

Sine FM, Leads, Percussion, Organs.

Triangle FM, Smooth Sounds, Bass, Flutes.

Square Smooth Basses, Leads, Synced Waves.

Parabolic Smooth Sounds, Pads.

Noise Ambient FX, Percussion.

Saw Rough Bass, Edgy Leads.

Pulse Vintage Synths, Pads.
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Oscillator 1 (OSC1)

OSC1 is the primary sound source in Discovery.  This oscillator uses the pitch of the 
incoming note and plays it in the specified waveform type. OSC1 can be one any of the 
following waveform types (shown from the top down):

● Sine.

● Triangle.

● Saw tooth.

● Parabolic (Saw tooth with red led).

● PWM (Pulse Width Mod).

● Square.

You can quickly switch between any waveform by simply left-clicking the button below 
the waveform list. A blue or RED LED indicates the currently enabled waveform.

Frequency Modulation: Discovery features a true frequency modulation (FM) engine, 
allowing the OSC1 carrier wave to be modulated by frequency of the OSC2 output.

FM Amount: Sets the amount of FM used to modulate OSC1 frequency.
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Oscillator 2 (OSC2)

Discovery offers a second oscillator, which adds additional sound design capabilities to 
your patches.

The second oscillator may be used in various ways 
such as mixing with, or modulating the frequency 
of OSC1.  

OSC2 can be set to any of the following 
waveforms:

● Triangle.

● Saw.

● Parabolic (when Saw led is red).

● PWM (Pulse).

● White Noise.

● Pink Noise (Noise with red led).

● Square.

Controls for oscillator 2 are:

● Semitones: This knob allows you to shift the pitch of OSC2 from -60 to +60 
semitones.  The following features apply:

○ When in use, a blue LED will activate at full scale values:

-60, -48, -36, -24, -12, 0, 12, 24, 36, 48, 60

○ When OSC SYNC mode is active OSC2 will reset each time OSC1 finishes a 
cycle. (Explained below).

○ When noise wave is selected, this control is used to determine the frequency 
range of the noise (from low frequency to high frequency noise).

If noise wave is selected and OSC SYNC mode is active, the semitones control is a 
digital noise wave selector, from a table of  8 different random sound shapes.

● Fine Tune: Fine-tuning of OSC2 from a range of -0.5 to +0.5 semitones.

● KBD Track switch: When on, the OSC2 will track pitch of incoming note.
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Oscillator Modes

● Pulse Width: Determines the de-phasing amount between the two saw tooth 
waves that build up the Pulse wave.  This results in the pulse width of BOTH 
oscillator pulse wave shapes (only works for PWM).

Lesser values (turned left) result in a square formed PWM.  Higher values result in a 
train of small pulses.

● OSC SYNC: OSC2 phase will reset each time OSC1 completes a cycle, giving 
harsh and fuzzy effects on the OSC2 sound.  In this mode the OSC2 semitone 
control will not determine the pitch shift, but rather the harmonic content of the 
wave that will modify the pitch of the OSC1.

● RING MOD: OSC1 output will multiply the OSC2 output. When this mode is turned 
on, the FM control in the OSC1 will work as pitch tune (in the range of 0 to +12 
semitones) for the OSC1.  This mode can be used for special effects and ambience 
sound shapes.

● OSC MIX: Used to mix both oscillators output.  Knob values follow:

○ Left: 100% OSC1 Signal.

○ Middle: 50% OSC1 Signal, 50% OSC2 Signal.

○ Right: 100% OSC2 Signal.
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Wave Oscillator (WAVE)

Discovery Pro offers a third oscillator, which adds dramatic sound design capabilities to 
your patches.

Wave oscillator can be edited by clicking the LED located at the right of WAVE label. 
Sound banks and waves can be selected by clicking < and > controls or clicking at the 
LED area to display a drop-down menu.

To add your own sound banks just zip a set of WAV files and use .dwb extension, or 
select a SoundFont 2 (SF2) file. Then place it on Documents > discoDSP > Discovery 
Pro > Waves folder and they will appear next time Bank LCD is clicked.

Controls for Wave oscillator are:

● PAD Button: For any active wave, Discovery Pro will render a new waveform set 
using PAD synthesis. It will generate a perfectly looped and beautiful set of 
sounds, no matter what the source is.

Since it's a very complex method, it will generate a cache file in SFZ + 20 WAV 
files (or 1 WAV when ECO mode, displaying a ECO or green button) per sound at 
Discovery Pro > Cache > PADCache or Discovery Pro > Cache > 
PADCacheEco folder.

Next time PAD is active, it will read the file from cache, resulting in fast loading 
time.

● Semitones: This knob allows you to shift the pitch of Waveforms from a wide 
range of semitones.  The following features apply:

○ When in use, a blue LED will activate at full scale values:

-60 / -48 / -36 / -24 / -12 /  0 / 12 / 24 / 36 / 48 / 60

○ When Keytrack is selected, pitch changes will be applied across the keyboard.

● Fine Tune: Fine-tuning of loaded Waveforms from a range of  semitones.
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FM mode in the Wave Oscillator using the FM LED: In this mode, Oscillator 1 serves as 
the carrier, while the modulation amount is derived from the Wave file through Oscillator 
2's FM knob.

TIPS

● To alternate between VA OSC On/Off for both OSC1 and OSC2, you can click on 
the LED.

Clicking on the OSCILLATORS label allows you to switch between Phase Retrig 
and Free Run Phase for both oscillators.

This adjustment method simplifies the process of controlling the oscillators’ 
functionality, facilitating easy toggling of their operational states—either 
deactivating them when only the WAVE oscillator is needed or managing their 
phase settings.

● Full octave switching can be easily performed by clicking + and – labels.
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Filter Section

Once oscillators are mixed, sound is next routed through the Discovery filter section.  This 
section will transform the frequency response of the signal.

A filter is a unit that changes the magnitude of a range of frequencies of the sound, 
boosting or cutting these frequency values.  

Basic Filter controls

The two most common filter parameters are the Frequency and Resonance controls.

● Frequency: or 'cutoff' point.  This value sets the frequency point affected by the 
filter response.

● Resonance: This value determines the amount of amplification of the range of 
frequencies surrounding the frequency (cutoff) point.
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Filter Types

Discovery Pro has 12 filter types. You may toggle through these types using the buttons 
below the LCD Filter Type section or by clicking filter name LED to make a drop down 
menu appear. The active filter is also showed in the display.

Available filter types follow:

● LowPass 12db: This 2 pole Lowpass filter will cut all spectrum range above 
the Cutoff frequency, with a rolloff of -12dB per octave.

● BndRjct 24: The Notch filter will cut the frequency range surrounding the Cutoff 
point, and will be processed thru the 24dB Lowpass filter explained above, but 
using a slightly shifted Cutoff frequency.  Using this with high Resonance amounts 
will result in interesting vocal formants effects.

● LowPass 24db: A 4 pole Lowpass Filter with -24dB per octave rolloff. This 
functions similar to the LP 12db, but with a steeper frequency curve response.

● BndPass 24: A Bandpass Filter, which allows only the frequency range 
surrounding cutoff point to pass through. Resonance controls the size of this 
bandwidth.

● HghPass 24: The opposite of the Lowpass filters, the Highpass will pass 
frequencies above the cutoff point and will cut all range below. This filter type has 
a rolloff of -24dB per octave.

● HghPass 12: Will pass frequencies above the cutoff point and will cut all range 
below. This filter type has a rolloff of -12dB per octave.

● Formant: 2 bandpass parallel filters tuned in vocal formant frequency range. 
Resonance modifies both filters resonance.

● X 12: A Moog modeled 2 pole Lowpass Filter with -12dB per octave rolloff.

● X 24: A Moog modeled 4 pole Lowpass Filter with -24 dB per octave rolloff. It 
functions similar to X 12db, but with a steeper frequency curve response..

● Y 12: Another Moog modeled 2 pole Lowpass Filter with -12dB per octave rolloff.

● Y 24: Another Moog modeled 4 pole Lowpass Filter with -24 dB per octave rolloff. 
It functions similar to Y 12db, but with a steeper frequency curve response.

18



Filter Envelope

The Filter Envelope allows easy ADSR (Attack, Decay, Sustain, Release) envelope based 
modulation of the filter Cutoff control.

● Attack: Controls for the time in which the filter envelope moves from 0 (note play) 
to full filter (based on the Envelope Amount, below).

● Decay: Controls the time length between the end of attack and the sustain level.

● Sustain: Sets the filter point at which envelope stays while note is continually 
pressed, once attack and decay have completed.

● Release: Begins once the note is released, controlling the time the gain will fall 
from current envelope point (Sustain) until complete.

● Env Amount: The Envelope Amount option controls the amount of the Filter 
envelope applied to the Cutoff frequency.  

● Vel: When enabled, the Envelope Amount will be scaled with the incoming note 
based on velocity.  This results in more dramatic envelopes for harder hit notes.

Additional Filter Options

● Keytrack: When active, Keyboard Tracking will increase the filter cutoff frequency 
based on incoming note pitch.  Higher notes will add higher frequencies to the 
current filter cutoff point.

Tracking can be 1/2 (minor), 2/3, or Full (very drastic).

● DIST: Distortion effect with dual modes. Starting with Release 8.2, distortion will 
always be oversampled at 2X.

○ Asymmetric Distortion: This will apply saturation to the negative field of the 
signal. This will generate side harmonics, useful for tube distortion effects.

○ Symmetric Distortion: Saturation will be applied symmetrically, resulting in 
odd harmonics, useful for grunge or distortion effects.

○ Asymmetric Distortion 2: A variation of first asymmetric distortion.
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Modulation Section

Low Frequency Oscillator 1 (LFO1)

Discovery Pro includes two LFO's (Low Frequency Oscillators), a Modulation Envelope 
(with 2 stages and state variable amount control) and a Graphic Envelope Generator. LFO 
oscillators operate much like the basic Discovery oscillators, only at much slower speeds

Rate: This control sets the speed (frequency) of LFO1.  Smaller values result in slower 
oscillations, larger values in faster oscillations.

LFO1 can use various waveforms (from top to bottom):

● Lowpass Random: Like random waveform, but the value is a smooth curve.

● Square: If LFO1 phase is above the half of the period length, the LFO will take the 
highest value, otherwise the lowest.

● Triangle: Also a ramp, but moves down to up, then back to down in a single cycle. 
Primarily used for sweep effects.

● Saw Tooth: Ramp shape; will move up to down, then instantaneously up when 
cycle is completed.

● Random: Each time LFO1 completes a cycle, it will select a new random value.

Re-triggered LFOs: By cycling through LFO waveform options a second time you can 
enable Re-triggered LFO's. This means LFO will be restarted each time a note is played. 
Re-triggered LFO's are indicated by red LEDs.
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Destination: To the left to the waveform selector is the LFO1 Destination selector.  This 
feature allows you to choose which control(s) this LFO will modulate. The following LFO1 
modulation destinations are available:

● FM: OSC2 to OSC1 FM (Frequency Modulation) amount.

● FILTER: Filter cutoff frequency.

● OSC2: OSC2 pitch.

● OSC1+2: Both OSC1 and OSC2 pitch.

● PW: Width of the pulse of PWM waveforms.

Amount: LFO1 Amount control determines the amount of LFO output to use on the 
destination control(s).  Higher values will result in a more dramatic modulation.

Low Frequency Oscillator 2 (LFO2) and Arpeggiator (ARP)

Second LFO operates much like the first, yet without a selectable waveform.  LFO2 is 
always a pure sine wave. In addition LFO2 has a powerful Arpeggiator (explained below).

Rate: Controls the speed (frequency) of LFO2.

Destination: The following destinations are available to LFO2:

● OSC1+2: Both OSC1 and OSC2 pitch.

● AMP: Amplitude (Creates a Tremolo effect).

● FILTER: Filter cutoff frequency.

Amount: LFO2 Amount control determines the amount of LFO output to use on the 
destination control(s).  Higher values will result in a more dramatic modulation.
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LFO2 Arpeggiator

ARP: You can enable Discovery's Arpeggiator by left-clicking the ARP button in the LFO2 
section.  When active, LFO2 operates in ARP (Arpeggiator) mode.

An Arpeggiator is basically a simple sequencer which continually plays notes 
automatically as a note or notes are held.  The notes played depend of the keys currently 
pressed and the arpeggiator range.

Rate: When in ARP mode, the Rate control sets the arpeggiator tempo.  Faster values 
may be achieved with greater values (turning the knob to the right).

Destination: In Arp mode, direction in which the Arpeggiator will play notes. They can be:

● DWN: Plays notes from highest to lowest, then restarts.

● U&D: Repeats playing highest lowest, then back from lowest to highest.

● UP: Plays lowest to highest, restarts.

● RND: Plays any random note from the arpeggiator range.

● RND2: Play to the next or the prior note in the arpeggiator range randomly.

Arp Rng: Sets range in octaves for the arpeggiator, from 1 to 5 octaves.

Modulation Envelope

Modulation envelope is a simple envelope which includes 2 stages, attack and decay.

Attack: Changes the value of the destination (based on the Amount) from the time a key 
is pressed until its highest point.

Decay: Changes the value of a destination (based on the Amount) from the highest point 
until the sustain level is reached.

Destination:  The following destinations are available to the Mod Envelope:

● FM: Frequency Modulation Amount.
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● PW: Pulse Waveform Width.

● OSC2: OSC2 Pitch.

● O2+W: OSC2 and WAVE pitch.

Amount: Sets modulation. This modulation can be positive, negative, or anything in 
between. Three basic settings include:

● Negative: All the way to the left, reduces the destination.

● No Amount: Center, disabled.

● Positive: All the way to the right, increases the destination.

Graphic Envelope Modulation

Graphic Envelope modulation is located between GATE and WAVE sections. Just left-
click the blue LED close to MOD label for easy panel access.

Configuration is done in the same fashion as Gate, left-clicking the bars with your mouse 
in order, with the only difference of being able to set individual amounts for each one. 
Clicking and holding your mouse button will allow to easily draw custom modulations and 
the drop down menu allows to select tempo sync speed to 0.5x, 1x or 2x (linked to Gate).

Destination: This feature allows you to choose which control(s) this envelope will 
modulate. The following graphic envelope modulation destinations are available:

● OSC2: OSC2 pitch.

● FM: OSC2 ® OSC1 FM (Frequency Modulation) amount.

● PW: Width of the pulse of PWM waveforms.

● FILTER: Filter cutoff frequency.
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Amplifier

Discovery's amplifier applies an envelope to the output gain of the current layer of sound.  
This is the final stage of synthesis. The following controls apply:

● Attack: Controls for the time that envelope moves from note press (0) to full 
volume. (Does not apply to legato mode).

● Decay: This knob controls the time length between envelope gain goes from upper 
point (end of Attack) to Sustain level.

● Sustain: Sets the point at which the envelope stays while note is held.  This state 
is held until the note is release.

● Release: Once the note is released, this knob will control the time in which the 
gain will fall from current envelope point (Sustain) into complete silence, finishing 
the voice use. 

Longer releases can result in many simultaneous voices, resulting in high CPU 
usage.

● Gain: Adjusts the overall volume for the current layer. Use morphing to add 
dynamics.

● Limiter: AThere are three limiter states: Off, where no processing is applied; Red 
Highlight, which activates a full-band limiter with an -Inf:1 compression ratio to 
prevent peaks; and Blue Highlight, introduced in version 8.4.1, which enables a 
powerful multiband limiter with a harmonic exciter for enhanced clarity and 
perceived loudness. The multiband limiter processes frequencies separately, 
maintaining dynamic range while effectively controlling peaks.

Discovery Pro can also switch from default linear 
envelope behavior to exponential, which is usually 
better for pads, by clicking the LED next to each knob.

Once LED is enabled, that particular envelope stage will 
use exponential values instead linear.
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Panning, Delay/Echo and Gate

Discovery has built in stereo delay, panning and gate effect units.

Panning

This effect can be used to widen a sound or give it interesting panning effects per layer. 
You can sync Mod Rate to host tempo by clicking the led located next to Mod Rate knob.

● Position: Position in the stereo field.

● Modulation Rate: Controls the rate of the stereo modulation.

● Modulation Amount: Controls the depth of the stereo modulation.
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Delay/Echo

This effect can be used to add spacey echo effect, or widen a sound. You can sync 
Left/Right Delay to host tempo by clicking the led located between Left and Right knobs.

● Level: Controls the amount of the delay effect.  No Level value (knob turned 
completely to the left) will disable the delay effect. This control is morphable as 
well.

● Left / Right Delay: Controls the delay time of the unit for each channel.

● Left / Right Feedback: Controls the time of the delay tail.  Moving this knob to the 
right will increase the tail.

● Cross switch: Adds a cross-feed to the feedback output. This will result in a 
stereo bouncing delay, useful for 3d-alike effects.
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Gate

To activate the Gate page effect, click the small blue LED next to GATE.

• Level: This controls the intensity of the gate floor effect. Setting the Level to its 
maximum (by turning the knob completely to the right) will turn off the gapper 
effect. This feature is morphable and operates independently across layers, making 
it ideal for creating complex sound textures.

• Gate pattern: This controls the triggering of the gate. The EDIT dropdown menu 
provides options to select the tempo sync speed at 0.5x, 1x, or 2x, which is linked 
to the Mod setting.

• Copy: This function allows you to copy the current gate pattern into memory.

• Paste: This function pastes the gate pattern from memory onto the current gate.

NOTE: It is possible to enable or disable multiple gate steps by clicking and dragging the 
mouse across the pattern.

TIP: By holding Shift while clicking and dragging the mouse, the value of the last cell will 
be applied.

TIP: In Windows, using a left click, or Ctrl + Click in macOS, over the current cell will open 
a dialog window for entering a numeric value.
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Importing and Exporting SysEx

Discovery can import or export SysEx patch dumps from software able to record MIDI 
SysEx data dumps.

On Discovery GUI, press EDIT  > File > Import / Export Nord Lead 2 SysEx

Keep in mind full bank patch imports will be placed into current selected layer. Also, 
imported Nord Lead 2 sounds may sound slightly different. Performance and Percussion 
Kits dumps are not supported.

Unison Edit

Unison is a pretty simple editing command, able to be customized. It takes the values 
from the first layer (A) and applies it over all of them (A, B, C and/or D) depending of the 
preset. 

If we open unison.txt located at Documents > discoDSP > Discovery Pro > Config 
using Edit > File > Open Unison we can see a list of default presets and the way how 
new ones can be made. Let's take a look at the first one: Double, which is the name 
displayed.

Double   1 1 0 0  0.5 0.5 0 0  0.2 0.8 0 0  0 0 0 0  0.3 0.7 0 0

● First four values mean that only Layers A and B will be affected 1 1 0 0 where A 
(1) B (1) C (0) D (0). 

● Second values are gain. 0.5 in a 1 to 0 range means Layers A and B will have 50% 
gain each. 

● Third values are panning. Layer A will be panned about 25% Left and Layer B 
25% right. 

● Fourth values are osc2 octave pitch shift. Since values are 0 they will all remain 
in the same octave.

● Fifth values are the osc2 fine-tune. As we can see Layer A and B will be detuned 
about 25% up and down respectively.

Adding and removing presets is as simple as removing or copy/paste a line and saving.

Edited Unison presets will take effect next time Discovery is instanced.
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MIDI

MIDI menu has been introduced on Release 7.1 and expands the original MIDI CC 
features.

MIDI Learn

This function will replace the default MIDI CC mapping file Default.xml located at 
Documents > Discovery Pro > MIDI folder. Values can be seen at Help > MIDI CC too.

Learn a MIDI CC
Select MIDI Learn.
Select a knob or button with the mouse
Send MIDI CC data with the hardware
Custom.xml file from Documents > Discovery Pro > MIDI folder will be updated.

MIDI CC Buttons

This is an extension for Discovery Pro buttons. Once switched, Discovery Pro will apply 
MIDI CC buttons table. You can find them using Help > MIDI CC or opening any XML file 
located at  Documents > Discovery Pro > MIDI folder.

MIDI Out

If enabled Discovery Pro MIDI will be sent. 

MIDI CC Hardware Board Templates

Discovery Pro includes several hardware board templates.

You can create your own by creating a copy of any XML file and renaming it to your board 
name and editing the CC with a text editor or using MIDI Learn and then creating a copy 
with the hardware board name.

Note: Nord Lead 2 and 4 templates will automatically switch to a MIDI CC oscillator that 
syncs the selected waveform oscillators with the hardware.
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Version History

Release 8.7.6

● Fixed previous build VST2/VST3 crash upon initialization.
● Pre-initialize all oversamplers during audio preparation to prevent real-time 

memory allocation.
● Eliminated unsafe oversampler resets during audio processing that could cause 

crashes.
● Fixed oversampling configuration persistence issues that reset settings 

unexpectedly.
● Fixed delay timing inconsistencies across all oversampling rates (2x, 4x, 8x).
● Corrected synced delay calculations to maintain consistent musical timing.
● Increased delay buffer size 4x to improve maximum delay times at higher 

oversampling rates.
● Enhanced delay time clamping for larger buffer capacity.

Release 8.7.5

● Simplified high-performance AlignedArray implementation for improved audio 
thread performance.

● Removed thread synchronization overhead from memory allocation routines
● Fixed Mac compatibility issues with memory alignment.
● Streamlined memory management for reduced CPU overhead during audio 

processing.
● Fixed bounce oversampling crashes: Resolved heap corruption issues that 

occurred during bounce processing by eliminating memory allocation on the audio 
thread.

● Improved oversampling stability: Prevented oversampler destruction crashes by 
maintaining proper object lifecycle management.

● Enhanced bounce mode transitions: Added robust buffer pre-allocation to avoid 
runtime memory issues when switching between realtime and bounce modes.

● Fixed oversampling state management: Properly restore playback oversampling 
settings after exiting bounce mode.

● Added memory safety checks: Implemented null pointer protection and allocation 
success validation in AlignedArray.

Release 8.7.4

● Added Nord-style real-time envelope updates supporting UI controls, automation, 
MIDI CC, mod wheel, and aftertouch.

● Fixed aftertouch scaling.
● Enhanced wavetable performance with 64-byte aligned wavetables and thread-

safe array implementation.
● New SIMD optimized wave resampling functionality.
● Corrected wavetable generation with improved bounds checking.
● Fixed deprecated Font constructors usage.
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● Resolved integer precision loss warnings with proper static cast implementations.
● Added virtual destructor to Discovery Scalable Object class.
● Fixed field initialization order in some DSP classes.
● Corrected integer overflow WaveVoice.h offset calculation.
● Enhanced InputStreams fread conversion to prevent precision loss.

Release 8.7.3

● Fixed critical memory alignment corruption during bounce/offline processing that 
caused crashes.

● Resolved race conditions in oversampling mode transitions between realtime and 
non-realtime processing.

● Enhanced buffer management to prevent memory corruption during high 
oversampling rates.

● Improved error handling and fallback mechanisms for oversampler initialization 
failures.

● Pre-allocate aligned audio buffers to avoid memory allocation during audio 
processing.

● Added bounds checking to prevent buffer overruns during oversampled 
processing.

● Enhanced pointer alignment validation before memory deallocation.
● Maintained proper alignment of layer buffers throughout oversampling operations.
● Eliminated unsafe pointer switching that could cause memory corruption.
● Improved decimation process for oversampled layer data.
● Enhanced exception handling for oversampler operations.
● Streamlined oversampling mode detection and configuration.

Release 8.7.2

● Fixed memory alignment crashes on macOS/Linux by replacing malloc with 
posix_memalign for proper memory alignment.

● Added comprehensive thread safety with mutex protection for aligned array 
operations.

● Enhanced AlignedArray class with move constructors, copy operators, and proper 
RAII memory management.

● Added alignment validation and error checking for memory allocation failures.
● Fixed NULL pointer dereference crash by implementing proper release.
● Added comprehensive audio buffer cleanup and voice state reset on plugin 

shutdown.
● Enhanced oversampler and effects cleanup with proper resource deallocation.
● Improved MIDI buffer and timer management during resource release.
● Fixed master volume not being restored when exiting Quick Stack mode.

Release 8.7.1

● Fixed layer on/off clicking button logic with improved selection and toggle 
behavior.

● Bank dropdown now displays factory filenames first in the list.
● Added File > New Bank function for creating empty bank files.
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Release 8.7

● Oversampling Engine Overhaul
◦ Completely rebuilt oversampling architecture using advanced IIR/FIR filters.
◦ Added 8x oversampling mode for ultimate audio quality.
◦ Full migration to new AudioBuffer code for modern, robust audio processing
◦ Removed legacy oversampling code and 2x undersampling mode for 

consistent quality.
◦ Added "Same as Playback" option for Bounce Quality settings.

● Audio Quality Improvements
◦ Enhanced anti-aliasing performance for distortion and waveshaping.
◦ Significantly reduced digital artifacts, especially at frequency extremes.
◦ Improved noise oscillator with compensation for different oversampling rates.
◦ Fixed FM modulation rate inconsistency across oversampling modes.
◦ Updated limiter to properly adjust frequency bands based on sample rate.
◦ More accurate stereo imaging and better transient response.

● Performance Optimizations
◦ Enhanced buffer handling for more efficient memory usage.
◦ Modernized MIDI processing code with range-based loops.
◦ Updated AudioPlayHead position handling to use modern API.

● Interface & Control Improvements
◦ Fixed morph bitmap display for knobs at min/max position.
◦ Added native macOS dialog for preset renaming with proper character limit 

enforcement.
◦ Reorganized Playback and Bounce oversampling menus with logical grouping.
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Release 8.6

● Memory Optimizations
◦ Moved large wavetable arrays from stack to heap memory using 

std::unique_ptr to avoid stack overflow issues.
◦ Added wavetable 64-byte alignment for optimal cache line usage.
◦ Implemented prefetching for better cache performance.

● Performance Improvements
◦ Replaced bubble sort with std::sort for faster MIDI event processing.
◦ Optimized wavetable linear interpolation formula.
◦ Added branchless operation for oscillator shape functions.
◦ Implemented function branchless lookup using bit manipulation.
◦ Added compiles optimizations.

● Bug Fixes
◦ Fixed wavetable file loading and regeneration.
◦ Corrected MIDI pitch wheel handling to properly process 14-bit values.

Release 8.5.5

● Added Playback Quality and Bounce Quality submenu items to the voice 
configuration.

Release 8.5.4

● Redesigned active gate/mod LED position for better visibility.
● Fixed Tick to Grid function for more accurate grid interactions.
● Added basic SFZ instrument collection.
● Added support for SFZ location subfolders.
● Implemented SFZ parser optimizations for better performance.
● Improved SFZ parsing capabilities.
● Fixed SFZ wavebank menu: Now displays as submenu instead of flat item.

Release 8.5.3

● Implemented preliminary SFZ support (Waves > SFZ folder).
● Fixed mono play mode clicks.
● Fixed memory leaks related to DWB processing and improper File path handling in 

Wave Player.
● Consistently select first wave when switching wave banks.
● WavePlayer DWB caching.
● Optimized DWB loading with 256KB buffers and caching for 5-20MB DWB files.
● Enhanced unison voice allocation in mono/legato mode for consistent detune 

ordering.
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Release 8.5.2

● Added MTS-ESP support for microtuning. Status available at Help Menu.
● New Unison Detune settings at Voices LED or MENU > Edit > Config, modeled 

from the Nord Lead 2 detune modes.
● Improved activation dialog and user interface.
● Optimized New Limiter function with faster DSP processing.
● Improved oversampling with critical fix for proper filter coefficients across all 

modes.

Release 8.5.1

● UI & Usability Enhancements

◦ New Quick Stack Edit Mode recall: Press Shift + Layer button to enter Quick 
Stack edit mode.
Quick Stack now remains in the same layer after exit.

◦ Key and left-click button modifiers have been added for the Amp Limiter and 
Filter Distortion, enabling multi-layer control (Control/Option key) and reverse 
cycling (Shift key).

◦ Clickable KeySplit Editor label.
◦ Updated LCD display for Oscillator Modulation Mode, Amplitude Envelope 

Shape, and Filter Keyboard Track buttons.

● Audio Processing & Performance Improvements

◦ New Advanced Limiter featuring multi-band processing, adaptive attack and 
release times, per-band envelope tracking, and harmonic enhancement for 
transparent peak control. It splits the signal into low, mid, and high frequency 
bands, applying warmth through soft clipping and frequency-dependent 
harmonics.

◦ Processor host synchronization for all program change operations.
◦ Major framework update.

● Updated [11] Alan Marcero bank, powered by a meticulously balanced collection 
of 128 presets, this sound bank provides the perfect ratio of essential sounds. 
Featuring 25 earth-moving basses, 40 versatile leads, 15 lush pads, 44 precision-
crafted plucks, and 4 classic acid-inspired sounds.

34



Release 8.5

● Enhanced Voice-Stealing Performance: Improved voice allocation by prioritizing 
unused or released voices while protecting active ones, resulting in smoother note 
transitions and better handling of unison and layer settings.

● Smoother Playback: Fixed wave engine playback clicks for a more seamless audio 
experience.

● VA Oscillator Improvements: Enhanced label handling and LED click functionality 
for a more intuitive user interface.

● GUI Refinement: Fully refactored internal GUI code for improved stability and 
maintainability.

● Stronger License Validation: Improved handling of license files by ensuring 
directories exist, checking file permissions before saving, and verifying readability 
during loading.

● Tutorial Component Updates: Enhanced the DiscoveryTutorialComponent to 
provide clearer user guidance.

● Streamlined MIDI Management: Updated MIDI menu creation for faster and more 
efficient setup.

● New Program Randomization: Added new function for randomizing programs 
directly from disk folders.

● Preset Save Fixes: Addressed warnings related to saving XML presets to ensure 
smooth operation.

● Audio Processing Update: Replaced deprecated functions in processBlock for 
improved compatibility and performance.

● Modernized Codebase: Replaced outdated functions like sprintf and 
roundFloatToInt with modern alternatives.

● Updated Math Constants: Improved handling of constants like PI and rounding 
functions for more accurate calculations.

● Refactored Code Patterns: Simplified and modernized internal code, including 
improvements to memory management with std::uni_ptr.
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Release 8.4.4

● New Markov Chain Arpeggiator mode: This mode enhances random arpeggiation 
by using machine learning techniques. It creates evolving musical patterns through 
a dynamic probability matrix that learns from its own note selections, generating 
sequences that are both unpredictable and musically coherent. Each note 
influences future choices, resulting in unique and captivating arpeggios.

● Enhanced VA Oscillator Label and LED Click logic: The LED Click and Label 
Shift+Click now toggle the oscillator On/Off and remember the last On state. When 
the label is clicked, if the oscillator is Off, it turns On to the last state. If the 
oscillator is already On, clicking the label toggles between Free Run and Retrig 
Phase modes. The last On state is always updated after changes, ensuring a 
seamless user experience.

● Fixed WAVE engine loop clicks: The WAVE engine has been refactored with up-to-
date and improved DSP techniques, eliminating unwanted loop clicks and 
enhancing overall audio quality.

● PI values on the DSP have been updated as long doubles: To further improve 
audio quality and precision, the PI values used in the DSP calculations have been 
updated to long doubles, ensuring more accurate mathematical operations and 
smoother sound generation.

● Updated XML save functions: The XML save functions have been updated to 
ensure compatibility, reliability, and efficient data management when saving and 
loading presets and settings.

● Refactored rounding integer functions: We have refactored some rounding integer 
functions to improve efficiency, resulting in faster processing and smoother overall 
performance.

Release 8.4.3

● We have enhanced the envelope handling to ensure filter and amp envelopes 
continue smoothly from the previous note's envelope point, resolving issues with 
incorrect retriggering. Additionally, portamento (glide) functionality in mono mode 
has been improved, particularly with the auto feature enabled. Now, portamento is 
correctly applied during legato play, ensuring seamless transitions between notes.

Release 8.4.2

● Resolved 2x oversampling sound issues and enhanced performance through 
unrolled loop optimization.
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Release 8.4.1

● Improved plugin GUI load times by optimizing the GUI initialization.
● Fixed an issue with the oversampler initialization.

Release 8.4

● Oscillator Optimizations: Optimized the filter and oscillator code for enhanced 
performance on x86 processors, with substantial performance improvements on 
Apple ARM processors.

● Wave Oscillator optimization: Around 30% faster processing by moving from scalar 
to SIMD processing. This includes new NEON code for ARM processors and 
optimized SSE4.1 instructions for faster, more efficient performance. 

● Filter Improvements: Introduced a more optimized tangent plot using scalar 
optimizations, effectively reducing CPU load and improving efficiency.

● 4x Oversampling: Implemented 4x oversampling to significantly enhance audio 
fidelity, ensuring superior sound quality for the end user.

● New Bounce Oversampling Configuration: Added a Bounce.xml file for configuring 
oversampling during offline rendering. The default is set to 4x oversampling for 
optimal sound quality, but it can be adjusted to lower settings if necessary. This file 
is located in the Documents > discoDSP > Discovery Pro > Config folder.

● New Default Settings: Configured to 16 voices and 2x oversampling. Users can 
change this through the Edit Menu or by clicking the Voices LCD.

● Updated LCD status sections: Display the current waveform and destination for 
LFO1, Arp Mode, and destination for LFO2/Arp, and the waveform for both 
Oscillator 1 and 2 when buttons or LEDs are pressed.

● 2x Undersampling improvements: Fixed gain compensation issue.

Release 8.3

● New Modulation Gate Randomizer: We have introduced a new modulation gate 
randomizer function that incorporates waveform-based oscillations. This 
enhancement allows for more dynamic and varied rhythmic patterns by applying 
different waveforms (sine, square, triangle, sawtooth) to the modulation gates. The 
waveform type and phase are randomly selected, generating oscillating values that 
fluctuate between 0 and 1, resulting in a richer and more intricate rhythmic 
experience.

● New House Matrix Gate Randomization: In addition to the existing Jazz and 
Techno patterns, we have added a new House matrix gate randomization type. 
This pattern is specifically tailored to create more dynamic and interesting 
transitions, which are essential for house music. The House matrix features higher 
probabilities for staying in the same state or transitioning to adjacent states, 
promoting a smoother and more continuous rhythmic flow typical of house music, 
enhancing the overall musicality and feel of the generated patterns.

● The panning LCD display has been updated to show musical note values based on 
tick values. Now, when you adjust the panning, the display will show musical notes 
like 1/8, Dotted 1/8, 1/4, and so on. For longer durations, it will show bars (e.g., 3.0 
Bars).
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Release 8.2

● PADSynth clicks during rendering have been eliminated by implementing a 4-
sample fade-in and fade-out, ensuring smoother looping.

● The rendering time for PADSynth has been extended from 6 to 24 seconds, 
allowing for longer and more complex sounds.

● PADSynth files now include "loop enabled" and "loop point" tags in the SFZ 
format, improving compatibility with a wider range of third-party samplers, such as 
the Bliss sampler. This update aims at broadening PADSynth's usability across 
different digital audio workstations and sampler platforms.

● To ensure a fresh cache and optimal performance, the installation process now 
removes specific folders related to PADSynth's cache.

● MIDI Out functionality has been disabled when using ProTools to avoid conflicts 
with the new MIDI FX plugin type, enhancing stability and compatibility.

● The default number of voices has been increased to 64, allowing for richer and 
more complex soundscapes.

● The Popup Menu has been revamped, featuring a new, sleek black translucent 
background with rounded corners for a more modern and aesthetically pleasing 
user interface.

● Cursor behavior has been enhanced to change dynamically to a pointer in less 
obvious interactive areas, improving user interaction and navigation clarity.

● More robust online activation which handles some rare issues in Windows 
systems.

● Minor internal fixes and enhancements.
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Release 8.1

● Added Discovery Pro Sound Expansion to the registered version. This expansion 
enriches your sound library with 330 high-quality commercial presets, offering a 
wide range of sonic possibilities. Details of the included banks are as follows:
◦ Essentials Sound Bank: A versatile collection featuring 5 Sequences, 13 

Basses, 26 Leads, 18 Pads, and 2 Percussion Kits.
◦ Leading Sound Bank: A comprehensive set of 128 presets, including gated 

sounds, leads, pads, basses, keys, and effects.
◦ Pad Love Sound Bank: A specialized selection of 80 presets, dedicated entirely 

to pad sounds.
◦ Reaching The Stars Bank: An exclusive bank with 58 top presets for Discovery 

Pro, meticulously crafted by Mario Fest.
● Linux build.
● Relocated new VA Oscillator's HD Waves resources, resulting in a much smaller 

installer.

Release 8.0

DSP Improvements:

● Refined Oscillators: Experience enhanced detail in oscillators, with 2X 
improvement in both low and high frequencies.

● Advanced Distortion Modes: Enjoy 4X more precise distortion modes for added 
depth and character in sounds.

● Analog-Sounding Filters: Moog XY filters updated to provide 2X more analog-like 
warmth and texture.

Enhanced Preset Management with Disk Mode:

● New Disk Mode for easier browsing of presets and folders located in Documents > 
discoDSP > Discovery Pro > Presets > Programs.

● Switch between Bank and Disk Mode by clicking the BNK letter on the LCD.
● New file preset export functions available in the Edit menu.
● Expanded Preset Library offering a wide range of new presets to inspire and 

enhance musical creativity.

Other Improvements:

● Tick to Grid Value Conversion: Synced Tick values are now also displayed as grid 
values for a more traditional musical display, such as pentagram note bars.

● Framework update.
● Streamlined EDIT menu.
● Discovery Pro 8 is fully compatible with version 7. Projects and presets from 

previous versions will load seamlessly without any issues.
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Release 7.9

● Refined the Rhythmic Pattern Transition Probabilities and amalgamated them into 
a singular function. This function randomly selects patterns for standard, jazz, and 
techno matrixes.

● Introduced the feature under Edit > Randomize > Layer/Program from Disk. This 
feature loads a random layer or program from the available banks.

● Optimized zone presets and editing menus.
● Incorporated the edit Gate and Mod Repeat functions for 4, 8, and 16 cells.
● The Mod zone cell values can be modified numerically through a right-click (or ctrl-

click on macOS).
● The editing menu can be accessed from any location on the GUI in macOS using 

ctrl+click.
● Rename preset option now automatically focuses on the text input box.
● Resolved a tuning issue with the WAVE oscillator when the plugin is initiated on 

blank tracks.
● The WAVE import dialogue has been made more efficient.
● Revamped the popup menu to address display anomalies.
● Ensured that popup menus consistently display in a downward direction.
● Resolved a standalone MIDI Bluetooth malfunction occurring post-click.
● Updated the underlying framework.
● Integrated the most recent versions of VST3 and AAX SDKs.
● Addressed rendering complications pertaining to macOS Metal.

Release 7.8.3

● The VST3 build now utilizes a continuous parameter index for optimal graphical 
user interface (GUI) responsiveness.

Release 7.8.2

● Activation window issue, where it was opening in the background, has been fixed.
● A fix has been implemented to address a VST3 parameter issue.
● Default skin assets have received minor updates.
● The issue of noise running with license activation in some DAW hosts has been 

resolved.
● The message dialog for 'legacy banks not found' has been removed.
● Certain menus have been sorted for improved navigation.

Release 7.8

● New Silver Haze skin by Ilkka Rosma.
● Updated default Nordic Dawn skin.
● New Shadow Wave skin.
● Updated and new skins now include 30x and 40x assets for high-resolution 1.5x 

and 2x GUI size display.
● Fixed standalone program change function.
● Fixed Quick Stack behavior. Now, current layer blinks if it's active.
● Added octave submenus to Custom Key Split dropdown.
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● Clicking Key Split dropdown / led now rotates between Off, Dual, Custom, Custom 
(edit) states.

● Other minor fixes and enhancements.

Release 7.7.3

● Resolved an issue where the Standalone build was unresponsive to knobs on all 
OS systems.

● Rectified the problem of the WAVE octave LED not responding to clicks.
● New icon in the style of macOS Big Sur for the macOS standalone version
● Implemented improvements to enhance overall stability.

Release 7.7.2

● Fixed Popup menu behavior.
● Fixed Wave octave + - buttons and knob for accurate behavior.

Release 7.7.1

● Fixed a minor issue where multi-channel bus configuration was unavailable in the 
VST, VST3, and AU versions.

Release 7.7

● The ProTools AAX plugin has been compiled as a universal binary, with native 
support for Apple Silicon architecture.

● The license activation system has been integrated into the plug-in, eliminating the 
need to input the serial number during each installation.

● The Percussion banks [64] Percussion 1 and [65] Percussion 2 have been updated 
with oscillator phase reset enabled.

● New menu option 'Program' which lists the saved presets in Documents > 
discoDSP > Discovery Pro > Presets > Programs, providing quicker access to 
favourite presets.

● The Wave + and - Octave Shift buttons are now functioning correctly.
● Added the behaviour of the Shift + left click function on the oscillator label or LED 

to toggle only between its current On state and the Off state.

Release 7.6

● Oscillator phase reset feature, which can be accessed by clicking the oscillator 
label or selecting it from the menu under the "swap" option.

● Major update to the framework has been implemented.
● Optimized PADSynth rendering based on system specifications and number of 

CPU cores available.
● Fixed PADSynth issue where WAVE oscillator was muted after disabling PAD 

mode.
● Added AI-based pattern randomization with standard, jazz, and techno models for 

Gate and Mod Gates.
● Minor graphical user interface enhancements made.
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● New macOS icon has been added.
● "Save Program to Disk" function will allow the user to save the current program 

directly to the "Documents > discoDSP > Discovery Pro > Presets > Programs" 
folder.

Release 7.5

● Framework update with enhanced stability and reliability.
● AAX SDK update.
● Most GUI labels are now clickable.

Release 7.4.2

● Fixed filter attack MIDI learn and parameter issue.
● Fixed macOS GUI window always on focus issue.
● Fixed Nord Lead 2 SysEx preset and bank export issue.

Release 7.4.1

● Fixed macOS sound init issue.
● Fixed macOS parameter issue.

Release 7.4

● Framework update with enhanced stability and reliability.
● Universal 2 Binary ProTools AAX for future proofing.
● AAX plugin now compiled with the latest 2.4 SDK.
● Bypass FX now persistent across bank changes.
● Enabled 2X GUI size for HiDPI displays.
● Fixed Skins folders not working in Linux.
● Fixed MIDI XML templates not working in Linux.
● Fixed MIDI learn not working in Linux.
● Nord Lead 2/4 MIDI templates now mirrors sync oscillator type with the board.

Release 7.3.3

● Fixed SysEx import/export issue.

Release 7.3.2

● Active WAVE oscillator now displays correctly at popup menu.
● Fixed crash after clicking < or > on WAVE LCD.
● Fixed first bank preset WAVE not sounding after loading.
● Fixed issues with WAVE oscillator and AAX plugin.

Release 7.3.1

● Fixed AAX crashing ProTools after loading.
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Release 7.3

● New default Nordic Dawn skin by Ilkka Rosma.
● New edit menu skins selector.
● New Gate and Mod 0.5x / 1.0x / 2x speed switch under Edit drop down.
● Added Gate and Mod cell position highlight.
● Gate and Mod GUI fixes after reopening window.
● Fixed Shift + left click behavior in Gate and Mod cell editing.

Release 7.2

● Updated framework fixing VST3 parameter issues and greater stability.
● ProTools AAX support for Windows and macOS.
● Fixed AAX init patch bug.
● Linux VST3 build.
● Removed Linux curl dependency for greater compatibility.
● macOS Universal 2 Binary compiled with XCode 12.4 and new build system.

Release 7.1

● Universal 2 Binary for Apple M1 Silicon chips.
● Enhanced MIDI CC with board XML based presets and MIDI learn.
● Fixed drop down filter menu disappearing after click.
● Right click to morph support for all platforms.
● Mouse wheel support for knobs.
● Major framework update.
● Updated VST 3 SDK.
● GUI fixes.
● Critical Linux bug crash.

Release 7.0

● Active voices are now muted on program change.
● ASIO support in Windows Standalone app.
● EDIT menu redesign and enhancements.
● Enhanced preset interaction with AU and VST3 hosts.
● Fixed automation parameter display in Cubase VST3.
● Framework update for increased stability and compatibility.
● Full bank preset categorization. Now 100 banks available.
● macOS Standalone native menus and look & feel.
● Parameter refactor with enhanced automation and proper learn, touch and latch 

modes support.
● Preset list enhancements for VST3 and AU.
● Removed Linux Webkit component for increased compatibility.

Release 6.9

● Code signed files ready for macOS Catalina.
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● Rewritten multichannel bus configuration.
● Windows and Linux standalone.
● Linux standalone JACK support.
● New 128 presets bank by Thomas Hook.
● Major framework upgrade for enhanced compatibility and stability.
● Compiled with XCode 10.3, VS 2019 and Ubuntu 18. 

Release 6.8.1

● Fixed ADR LCD values in Windows build.

Release 6.8

● Drag and drop support for FXP / FXB / SYSEX / WAV / SF2 / DWB files.
● Gate and Modulation mouseover displays values.
● Modulation envelopes scroll wheel support.
● Removed OSC2 / WAVE semitone decimals from LCD display.
● Dynamic display for ADSR time values.
● Aftertouch displays amount in % and + - correctly.
● Fixed pitch bend issue importing Discovery banks.
● Fixed Quick Stack Master volume issues.
● Fixed MIDI to Velocity swap tick.

Release 6.7.1

● Fixed Phaser Filter issues.

Release 6.7

● Layer solo: Use Alt + click on slot / button to solo / unsolo layer.
● EDIT > File > Save Program to Active Bank.
● EDIT > Paste > Morph to all layers.
● EDIT > Paste > Pitch to all layers.
● Bank change controller 0 support.
● Fixed macOS bank change controller crash.
● Fixed Aftertouch mode not refreshing correctly.
● Fixed WAVE font size LCD.
● Fixed Empty WAVE Program/Bank display.
● Removed License.dat check.

Release 6.6

● Mac (x32/x64) / Windows (x32/x64) VST3 support.
● Multi-channel support.
● Mac standalone.
● Added 1.5x GUI size for Retina displays.
● GUI fixes and speed up by disabling image caching.
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Release 6.5.1

● Fixed Cubase issues.
● Updated framework for better stability and performance.
● OS X: Compiled with Xcode 7.3. OS X 10.6 or higher is required.

Release 6.5.0

● Added Retina GUI support for Hi-DPI displays including minor enhancements.
● Added 15 new banks and thousands of new waveforms. 10 banks reworked.
● Added License.dat copy protection. This file is provided at discoDSP Members 

Area or new purchases. It has to be placed at Documents > discoDSP > 
Discovery Pro folder to make the plug-in run.

● Added EDIT > Config > MIDI Out option.
● Added flat popup active option color.
● Fixed hanging notes issue.
● Fixed Linux file menu issues.
● Fixed Linux bank import.
● Increased performance and stability. 
● Data folder location changed to Documents > discoDSP > Discovery Pro.
● OS X: Compiled with Xcode 6.4. OS X 10.6 or higher is required. 

Release 6.4.6

● Fixed portamento behavior where only first unison voice was affected.
● Fixed delay copy/paste function.

Release 6.4.5

● OS X: Compiled with Xcode 5.1.1.
● Added shared memory to copy/paste layers/programs between Discovery Pro 

instances.
● Fixed inverse program change bug.
● Fixed OSC 2 noise to LFO1/2/MOD ENVELOPE - OSC 2 / OSC 1+2 rates behavior.

Release 6.4.4

● Fixed BandReject filter behavior.

Release 6.4.3

● Enhanced unison tuning.
● Fixed swapping programs voice channel management.

Release 6.4.2
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● Auto-loop for single cycle waveforms with less than 2048 samples.
● Auto-tune for unlooped waveforms.
● Enhanced voice stealing algorithm.
● Wave oscillator .wav fine-tune support.

Release 6.4.1

● Double clicking a knob resets to original position.
● Mod amount now reflects mouse values and OCT range correctly.
● Drop down menu from KeySplit hides after switching presets if it's displayed.
● Enhanced LCD fonts.
● Filter Attack MIDI CC changed to 38 (like NL2) on all platforms. 89 remains for FL 

Studio due compatibility issues.

Release 6.4

● New Nord Lead 2 modeled Unison.
● SysEx import now supports MIDI files.
● Enhanced SysEx Import.
● Edit > Swap > Bank > Chorus to Unison.
● Edit > File > Export Nord Lead 2 SysEx Bank.
● 1.5x / 2.0x GUI graphic fixes.
● Unison CC 16 / Phaser Chorus CC 50.
● Updated Help > MIDI CC.
● Banks 11 to 45 Chorus effect switched to Unison for better sound quality.

Release 6.3.1

● Fixed Graphic Modulation Envelope erratic behavior.
● Fixed PAD ECO button graphics.
● Fixed LCD Bank cell display graphics.

Release 6.3

● EDIT > GUI Size (1 / 1.5 / 2x) up to 1780x800 size.
● Full GUI code re-write. Faster, smoother, remarkable CPU usage reduction.
● Major internal structure re-write and clean up.
● Linux VST support.
● Revised manual.

Release 6.2

● New 128 voices polyphony option.
● Export program enabled in demo.
● SysEx export Nord Lead compatible.
● Reorganized and streamlined EDIT, preset menus and dialog windows.
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● Morphing values shown if  different from zero only.
● Broader bank/program LCD text.
● Midi CC # / Disabled added to EDIT > Swap > Aftertouch To.
● PADsynth button displays green if ECO mode is enabled.
● Fixed missing Wave.dat dialog hang.
● Fixed GUI background gradient misplacement.
● Fixed Quick Stack using Keysplit behavior.
● Fixed OSC 2 octave display LED bug.

Release 6.1

● EDIT > Quick Stack. Navigate thru any banks and presets without leaving current 
program.

● DWB 2.0 supporting embedded SF2 and Corona Wave Expansion DWB files.
● Multi-out per layer (VST only).
● EDIT > Paste > Layer to copies values from active layer instead memory.
● EDIT > Key Split > Custom. Configures A/B/C/D at any key range independently.
● Key Split GUI graphics display on current mode (off / dual / custom).
● Key Split Custom drop down menu switch / hide button (x).
● Revised manual.
● Bug fixes.

Release 6.0

● New Nord Lead 2 modeled filters using Zero Delay Feedback technology.
● Data folder now placed at Documents > discoDSP > Discovery Pro 6.
● EDIT > Reset > Bank / Program / Layer will get values from Documents > 

discoDSP > Discovery Pro 6 > Presets > Default.fxp file.
● EDIT > Paste > Layer to > All / A / B / C / D / A+B / C+D.
● EDIT > Switch > PadSynth Eco Mode. Re-synthesizes a single octave instead.
● EDIT > Key Split. Play Layers A/B from C0 to B3 and C/D from C4 to B9.
● Revised and tweaked 45 banks also updated to ZDF filters.
● Revised manual.

Release 5.6

● OS X 64-bit VST.
● Data folder moved to Documents > discoDSP > Discovery Pro with categorized 

folders.
● EDIT > Reset > Program and Layer read the settings from Documents > discoDSP 

> Discovery Pro > Presets > Default.fxp file now.
● EDIT > File > Import WAVE automatically places WAV files at discoDSP > 

Discovery Pro > Waves > User.dwb
● EDIT > Reset > Program Undo will revert back to the original preset located on the 

current bank.
● EDIT menu restyled to white text over black background.
● Added Paste to All, A, B, C, D at Zone Preset drop down menu.
● Enhanced Morph values. Tick values are show when synced to tempo.
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● Bug fixes.
● Manual revision.

Release 5.5

● Better FXP preset export compatibility.
● Renaming a preset shows the original name instead blank. 
● Overwrite warning when a bank file already exist.
● File dialog boxes now remember last opened locations.
● Banks located at Data folder refresh autocratically.
● Small EDIT menu fine-tune. 
● Manual revision.

Release 5.4

● 64 Bit Audio Units for Mac.
● 64 Bit VST for Windows.
● PAD resynthesized waves now render correctly under x64 OSes.
● Pitch and Mod Wheel events now recordable from GUI.
● MOD value mouse range behaves correctly now.
● Corrected arpeggio with MIDI Sustain behavior.
● EDIT > Reset > Layer Aftertouch.
● EDIT > Reset > Program Aftertouch.
● EDIT > Reset > Program Morphing
● EDIT > Bank import. Places FXB+DWB files at Discovery Pro Data folder.
● EDIT > Help > Release number added.
● EDIT > Switch > Aftertouch to > Aftertouch, Foot (CC# 4), Expression (CC# 11) and 

Breathe (CC# 2).
● Bug fixes.

Release 5.3

● Aftertouch support. EDIT > Switch > Aftertouch mode or Shift + Click ABCD 
button.

● Faster Sine Wave VA oscillator.
● MIDI CC Switch to edit Layers A-D using #63.
● EDIT > Help > Open HTML Manual.
● EDIT > File > Open Presets Folder.
● Drop down preset zone menus are alphabetically sorted now.
● Drop down presets available for WAVE zone.
● Wave OSC tabs order changed to WAVE DELAY GATE MOD.
● Bigger click area for Wave tabs.
● Optimized Program and Bank LCD display names.
● Small GUI restyling.
● Revised Manual.
● Bug fixes.
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Release 5.2

● WAVE LCD display now shows waveform numbers.
● Fixed clicks with Factory and Classics wave banks.

Release 5.1

● VST panel displays correctly in Cubase OS X.
● Better preset name handling in Zone Presets.
● Better behavior using Reaper.

Release 5

● WAVE PAD Synthesis Button. Re-synthesis of any active Wave using PAD 
algorithm, generating a SFZ file (Data Folder/PAD Cache).

● New Classic.dwb WAVE bank, including over 250 popular synthesizer waveforms.
● New voice stealing algorithm.
● 24-bit wave files support for User Bank (Data Folder/User.dwb).
● Help > Tutorials screen shots, MIDI CCs and Manual access.
● Edit > Smart Randomization.
● File > Nord Lead 2 SysEx Export.
● File > Open Data Folder.
● File > Open Unison Configuration.
● Edit > Config > MIDI CC Buttons switch.
● WAVE Active file is now marked in the drop down menu.

Release 4

● Zone presets. Each section can save individual presets based on the current state.
It's available by clicking the white small drop down menu icon located at the top 
left corner.

● Gate values are now displayed at the LCD when mouse is over.
● Engine fixes.
● Host compatibility fixes.
● Manual revision.
● Mac DMG image now includes alias to Audio Units, VST, RTAS and Plug-Ins 

folders for an easier installation.
● Apple GarageBand 09 and Logic 9 compatibility.
● RTAS version.

Copyright

Discovery Pro is © discoDSP. All rights reserved.
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